Study. uk . com
  1. Home
  2. All questions
  3. Question 48

CKA study material · question 48 of 1000

A kubelet refuses to start on a node that has swap enabled. Which configuration change lets it start?

  1. Set failSwapOn to false in the kubelet configuration
  2. Set evictionHard to zero
  3. Set cgroupDriver to cgroupfs
  4. Set swapBehavior to NoSwap
Show the answer

Answer: A. Set failSwapOn to false in the kubelet configuration

A kubelet fails to start when it detects swap unless swap is disabled or tolerated with failSwapOn: false.

Source: Installing kubeadm (Kubernetes) — Swap configuration

Challenge yourself on this topic → Study as cards