- Home
- All questions
- Question 411
CKA study material · question 411 of 1000
kube-proxy logs a failure to retrieve the node IP and falls back to 127.0.0.1. What happened?
Show the answer
Answer: B. It was scheduled before the cloud controller manager set the node's addresses
In cloud environments kube-proxy can start before the node addresses are initialised, which breaks its proxying.
Source: Troubleshooting kubeadm (Kubernetes) — kube-proxy scheduled before node is initialized by cloud-controller-manager